Page MenuHome

[FAWE] [Report Sent] //image not working
Closed, WontfixPublic


Notice: This is a suspected FAWE plugin functionality problem, and requires resolution from the plugin developers. Server staff cannot solve this.
Report: See FAWE Issue #208.

The WorldEdit command //image appears to not be functioning correctly.

MechanicalDog has tried using it, but received an error message asking for the creation of a directory FastAsyncWorldEdit/textures. I created this directory. The error message goes on to ask for a jar file, so I put that in as well, at FastAsyncWorldEdit/textures/.minecraft/versions/1.13.jar.

After I did what it asked, it spit out a separate error.

I can confirm the server does have read access to that area. I tried putting the file directly into the textures directory, and also tryed a 1.13.2 jar as well, all with the same result. A "bound must be positive" warning gets spammed console over and over, and a single pumpkin is placed down in the world.

Mech says that the //image function used to work back on Create. Perhaps Hex could look at how it is configured there?

Event Timeline

TheArchiteck triaged this task as Normal priority.
Hex added a comment.Aug 12 2019, 9:33 AM

Right, interestingly enough this appears to be involved with the X-11 Issue

[09:33:03 ERROR]: An unexpected error occurred while handling a FAWE command
java.lang.NoClassDefFoundError: Could not initialize class sun.awt.X11GraphicsEnvironment
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_65]
        at java.lang.Class.forName( ~[?:1.8.0_65]
        at java.awt.GraphicsEnvironment.createGE( ~[?:1.8.0_65]
        at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment( ~[?:1.8.0_65]
        at java.awt.image.BufferedImage.createGraphics( ~[?:1.8.0_65]
        at com.boydti.fawe.util.MainUtil.toRGB( ~[?:?]
        at com.boydti.fawe.util.MainUtil.readImage( ~[?:?]
        at com.boydti.fawe.util.MainUtil.readImage( ~[?:?]
        at com.sk89q.worldedit.command.GenerationCommands.image( ~[?:?]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_65]
        at sun.reflect.NativeMethodAccessorImpl.invoke( ~[?:1.8.0_65]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:1.8.0_65]
        at java.lang.reflect.Method.invoke( ~[?:1.8.0_65]
        at ~[?:?]
        at ~[?:?]
        at com.sk89q.worldedit.extension.platform.CommandManager.lambda$handleCommandOnCurrentThread$0( ~[?:?]
        at com.sk89q.worldedit.extension.platform.CommandManager.handleCommandTask( ~[?:?]
        at com.sk89q.worldedit.extension.platform.CommandManager.handleCommandOnCurrentThread( ~[?:?]
        at com.sk89q.worldedit.extension.platform.CommandManager$ ~[?:?]
        at com.boydti.fawe.object.FawePlayer.lambda$runAction$4( ~[?:?]
        at com.boydti.fawe.object.task.SimpleAsyncNotifyQueue.operate( ~[?:?]
        at com.boydti.fawe.object.task.AsyncNotifyQueue$ ~[?:?]
        at ~[patched_1.13.2.jar:git-Paper-642]
        at ~[patched_1.13.2.jar:git-Paper-642]
        at ~[patched_1.13.2.jar:git-Paper-642]
        at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:1.8.0_65]
        at java.util.concurrent.ThreadPoolExecutor$ [?:1.8.0_65]
        at [?:1.8.0_65]
TheArchiteck renamed this task from [FAWE] //image not working to [FAWE] [Reported] //image not working .Aug 22 2019, 7:56 PM
TheArchiteck lowered the priority of this task from Normal to Low.
TheArchiteck renamed this task from [FAWE] [Reported] //image not working to [FAWE] [Report Sent] //image not working .Aug 22 2019, 8:06 PM
TheArchiteck updated the task description. (Show Details)
This comment was removed by SirComputer.
Hex closed this task as Wontfix.Mar 27 2020, 4:31 AM

Unfortunately, this command was lost when moving to AWE. If FAWE ever becomes stable again, or something else comes up. I will be sure to try and get this back in.